CVE-2016-20101: Issuu Panel WP plugin: file inclusion enables RCE
HIGHIssuu Panel, a WordPress plugin before 1.6.6, has a PHP file inclusion flaw (CWE-98) in ajax-docs.php. An unauthenticated attacker can pass a crafted 'abspath' value to require() and run remote PHP code or read local files. Despite the 'ml_ui' tag, this is a generic WordPress plugin with no AI/ML-specific component and no tracked AI package affected, so exposure for AI programs is limited to WordPress sites that front or document AI projects. Exploitation evidence was first observed by Shadowserver on 2023-10-20, and a public Nuclei template and Packet Storm entry exist. The CVE is not in CISA KEV and has no EPSS score. Remote file inclusion needs allow_url_include enabled, which is off by default in modern PHP, so the CVSS 8.1 rating reflects high attack complexity. Upgrade to 1.6.6 or later, or remove the plugin if it is unused. Also check web logs for requests to ajax-docs.php with an abspath parameter.
What is the risk?
Severity is high (CVSS 8.1, network, no privileges, no user interaction, high complexity). Impact on confidentiality, integrity and availability is high. Attackers have exploited it in the wild per Shadowserver (2023), and public PoC material and a scanner template lower the skill needed. Remote inclusion depends on PHP configuration (allow_url_include), while local file inclusion can work more widely. Relevance to AI/ML is low and indirect: the plugin is a document-embedding tool for WordPress, not an AI component. Risk is mostly to the web server and any credentials stored on it.
How does the attack unfold?
How severe is it?
What is the attack surface?
What should I do?
1 step1) Update Issuu Panel to 1.6.6 or later, or remove the plugin; it is old and likely unmaintained. 2) Block direct access to menu/documento/requests/ajax-docs.php at the WAF or web server. 3) Make sure allow_url_include is disabled in php.ini and set open_basedir. 4) Search access logs for GET requests to ajax-docs.php with an abspath parameter, and scan for unexpected PHP files and web shells. 5) If you find signs of compromise, rotate the WordPress salts, database credentials and any API keys stored on the host. 6) Run the public Nuclei template (issuu-panel-lfi) against your own assets to find vulnerable instances.
How is it classified?
Which compliance frameworks are affected?
This CVE is relevant to:
Frequently Asked Questions
What is CVE-2016-20101?
Issuu Panel, a WordPress plugin before 1.6.6, has a PHP file inclusion flaw (CWE-98) in ajax-docs.php. An unauthenticated attacker can pass a crafted 'abspath' value to require() and run remote PHP code or read local files. Despite the 'ml_ui' tag, this is a generic WordPress plugin with no AI/ML-specific component and no tracked AI package affected, so exposure for AI programs is limited to WordPress sites that front or document AI projects. Exploitation evidence was first observed by Shadowserver on 2023-10-20, and a public Nuclei template and Packet Storm entry exist. The CVE is not in CISA KEV and has no EPSS score. Remote file inclusion needs allow_url_include enabled, which is off by default in modern PHP, so the CVSS 8.1 rating reflects high attack complexity. Upgrade to 1.6.6 or later, or remove the plugin if it is unused. Also check web logs for requests to ajax-docs.php with an abspath parameter.
Is CVE-2016-20101 actively exploited?
No confirmed active exploitation of CVE-2016-20101 has been reported, but organizations should still patch proactively.
How to fix CVE-2016-20101?
1) Update Issuu Panel to 1.6.6 or later, or remove the plugin; it is old and likely unmaintained. 2) Block direct access to menu/documento/requests/ajax-docs.php at the WAF or web server. 3) Make sure allow_url_include is disabled in php.ini and set open_basedir. 4) Search access logs for GET requests to ajax-docs.php with an abspath parameter, and scan for unexpected PHP files and web shells. 5) If you find signs of compromise, rotate the WordPress salts, database credentials and any API keys stored on the host. 6) Run the public Nuclei template (issuu-panel-lfi) against your own assets to find vulnerable instances.
What systems are affected by CVE-2016-20101?
This vulnerability affects the following AI/ML architecture patterns: WordPress web front-ends, Web-hosted documentation portals.
What is the CVSS score for CVE-2016-20101?
CVE-2016-20101 has a CVSS v3.1 base score of 8.1 (HIGH). The EPSS exploitation probability is 0.40%.
What is the AI security impact?
Affected AI Architectures
MITRE ATLAS Techniques
AML.T0049Exploit Public-Facing ApplicationAML.T0050Command and Scripting InterpreterCompliance Controls Affected
What are the technical details?
Original Advisory
Issuu Panel plugin for WordPress before 1.6.6 contains a PHP file inclusion vulnerability that allows unauthenticated attackers to include remote or local files through the 'abspath' parameter. Attackers can send GET requests to menu/documento/requests/ajax-docs.php with a crafted abspath value passed to require() to execute remote PHP code or include local files. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-20.
Exploitation Scenario
An attacker scans for WordPress sites exposing /wp-content/plugins/issuu-panel/menu/documento/requests/ajax-docs.php. They send a GET request with abspath pointing to an attacker-hosted PHP payload, or to a local file to disclose its contents. The server includes the file and runs the payload, giving a web shell. The attacker then reads wp-config.php and any stored credentials, including keys for AI services or cloud accounts used by the organization, and uses them to reach connected systems.
Weaknesses (CWE)
CWE-98Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')PrimaryCWE-98Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')CWE-98 — Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion'): The PHP application receives input from an upstream component, but it does not restrict or incorrectly restricts the input before its usage in "require," "include," or similar functions.
- [Architecture and Design] Use a vetted library or framework that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid [REF-1482].
- [Architecture and Design] When the set of acceptable objects, such as filenames or URLs, is limited or known, create a mapping from a set of fixed input values (such as numeric IDs) to the actual filenames or URLs, and reject all other inputs. For example, ID 1 could map to "inbox.txt" and ID 2 could map to "profile.txt". Features such as the ESAPI AccessReferenceMap [REF-185] provide this capability.
Source: MITRE CWE corpus.
CVSS Vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HReferences
- cxsecurity.com/issue/WLB-2016030131
- github.com/projectdiscovery/nuclei-templates/blob/main/http/vulnerabilities/wordpress/issuu-panel-lfi.yaml
- packetstorm.news/files/id/136398/
- wordpress.org/plugins/issuu-panel/
- vulncheck.com/advisories/issuu-panel-wordpress-plugin-1.6.6-file-inclusion-via-ajax-docs-php
Timeline
Related Vulnerabilities
CVE-2024-291210.0BentoML: RCE via insecure deserialization (CVSS 10)
Same attack type: Code ExecutionCVE-2026-2185810.0n8n: Input Validation flaw enables exploitation
Same attack type: Code ExecutionCVE-2025-512010.0smolagents: sandbox escape enables unauthenticated RCE
Same attack type: Code ExecutionCVE-2025-5952810.0Flowise: Unauthenticated RCE via MCP config injection
Same attack type: Code ExecutionGHSA-vvpj-8cmc-gx3910.0picklescan: security flaw enables exploitation
Same attack type: Code Execution