CVE-2025-5916: libarchive: WARC integer overflow causes local DoS
LOWCVE-2025-5916 is an integer overflow in libarchive's WARC parser: a crafted archive claiming more than INT64_MAX - 4 content bytes can trigger memory corruption or a crash in any application that extracts it. The direct risk is low (CVSS 3.9, local vector, low privileges, user interaction required), with no EPSS score, no public exploit, no Nuclei template, no CISA KEV listing and no SSVC decision. The reason it still matters to AI teams is reach: libarchive has 695 downstream dependents and is bundled in 30+ Red Hat OpenShift AI (rhoai) container images, including the MLflow, KServe, notebook-controller and training-operator images. The package also has 137 other CVEs and an OpenSSF Scorecard of 5.4/10, which points to weak upstream hygiene. Upgrade to libarchive 3.8.0 or later, or apply the Red Hat errata for the affected rhoai and OpenShift images through normal patch cycles. Do not treat this as an emergency.
What is the risk?
Low overall. Exploitation needs local access, low privileges and a user or process that opens a malicious WARC file. The CVSS vector rates confidentiality and availability impact as low and integrity impact as none. There is no EPSS data, no public exploit and no KEV listing, so exploitation likelihood is low. The AI/ML exposure is mostly through inherited container dependencies, not exposed services. The risk rises only where pipelines automatically ingest untrusted archives, for example web-crawl datasets stored as WARC files.
How does the attack unfold?
What systems are affected?
How severe is it?
What is the attack surface?
What should I do?
1 step1) Upgrade libarchive to 3.8.0 or later, or install the vendor-patched packages and images from Red Hat (see the CVE-2025-5916 advisory and Bugzilla 2370872). 2) Rebuild and redeploy custom images that bundle libarchive, then check the SBOM for vulnerable versions. 3) Do not process WARC files from untrusted sources in privileged or long-lived services. Run extraction in sandboxed, resource-limited containers. 4) Detect by monitoring for unexpected crashes or restarts in data-ingestion and archive-handling workloads, and by scanning container images for libarchive versions below 3.8.0.
How is it classified?
Which compliance frameworks are affected?
This CVE is relevant to:
Frequently Asked Questions
What is CVE-2025-5916?
CVE-2025-5916 is an integer overflow in libarchive's WARC parser: a crafted archive claiming more than INT64_MAX - 4 content bytes can trigger memory corruption or a crash in any application that extracts it. The direct risk is low (CVSS 3.9, local vector, low privileges, user interaction required), with no EPSS score, no public exploit, no Nuclei template, no CISA KEV listing and no SSVC decision. The reason it still matters to AI teams is reach: libarchive has 695 downstream dependents and is bundled in 30+ Red Hat OpenShift AI (rhoai) container images, including the MLflow, KServe, notebook-controller and training-operator images. The package also has 137 other CVEs and an OpenSSF Scorecard of 5.4/10, which points to weak upstream hygiene. Upgrade to libarchive 3.8.0 or later, or apply the Red Hat errata for the affected rhoai and OpenShift images through normal patch cycles. Do not treat this as an emergency.
Is CVE-2025-5916 actively exploited?
No confirmed active exploitation of CVE-2025-5916 has been reported, but organizations should still patch proactively.
How to fix CVE-2025-5916?
1) Upgrade libarchive to 3.8.0 or later, or install the vendor-patched packages and images from Red Hat (see the CVE-2025-5916 advisory and Bugzilla 2370872). 2) Rebuild and redeploy custom images that bundle libarchive, then check the SBOM for vulnerable versions. 3) Do not process WARC files from untrusted sources in privileged or long-lived services. Run extraction in sandboxed, resource-limited containers. 4) Detect by monitoring for unexpected crashes or restarts in data-ingestion and archive-handling workloads, and by scanning container images for libarchive versions below 3.8.0.
What systems are affected by CVE-2025-5916?
This vulnerability affects the following AI/ML architecture patterns: training pipelines, data ingestion pipelines, model serving, notebook environments, containerized ML platforms.
What is the CVSS score for CVE-2025-5916?
CVE-2025-5916 has a CVSS v3.1 base score of 3.9 (LOW).
What is the AI security impact?
Affected AI Architectures
MITRE ATLAS Techniques
AML.T0010.001AI SoftwareAML.T0011User ExecutionCompliance Controls Affected
What are the technical details?
Original Advisory
A vulnerability has been identified in the libarchive library. This flaw involves an integer overflow that can be triggered when processing a Web Archive (WARC) file that claims to have more than INT64_MAX - 4 content bytes. An attacker could craft a malicious WARC archive to induce this overflow, potentially leading to unpredictable program behavior, memory corruption, or a denial-of-service condition within applications that process such archives using libarchive. This bug affects libarchive versions prior to 3.8.0.
Exploitation Scenario
An attacker publishes or injects a crafted WARC file into a web-crawl dataset or shared storage that an ML data-preparation pipeline consumes. When a pipeline job or a user in a notebook workbench opens the file with a libarchive-based tool, the oversized content length triggers an integer overflow. The result is a crash of the ingestion job, which denies service to the pipeline. In the worst case it corrupts memory in the process. The attacker needs a way to get the file in front of a local process, and the impact stays limited to that process.
Weaknesses (CWE)
CWE-190 — Integer Overflow or Wraparound: The product performs a calculation that can produce an integer overflow or wraparound when the logic assumes that the resulting value will always be larger than the original value. This occurs when an integer value is incremented to a value that is too large to store in the associated representation. When this occurs, the value may become a very small or negative number.
- [Requirements] Ensure that all protocols are strictly defined, such that all out-of-bounds behavior can be identified simply, and require strict conformance to the protocol.
- [Requirements] Use a language that does not allow this weakness to occur or provides constructs that make this weakness easier to avoid. If possible, choose a language or compiler that performs automatic bounds checking.
Source: MITRE CWE corpus.
CVSS Vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:LReferences
- access.redhat.com/security/cve/CVE-2025-5916vdb-entryx_refsource_REDHAT
- bugzilla.redhat.com/show_bug.cgiissue-trackingx_refsource_REDHAT
- github.com/libarchive/libarchive/pull/2568
- github.com/libarchive/libarchive/releases/tag/v3.8.0
Timeline
Related Vulnerabilities
CVE-2025-1537910.0MLflow: RCE via unsanitized model dependency specs
Same package: mlflowCVE-2023-376510.0MLflow: path traversal allows arbitrary file read
Same package: mlflowCVE-2026-26359.8mlflow: security flaw enables exploitation
Same package: mlflowCVE-2023-27809.8MLflow: path traversal allows arbitrary file read/write
Same package: mlflowCVE-2023-11779.8MLflow: path traversal allows arbitrary file read/write
Same package: mlflow