CVE-2026-14212: Booking Calendar: IDOR enables employee account takeover
MEDIUMPoC AVAILABLEThis vulnerability affects the 'Booking for Appointments and Events Calendar' WordPress plugin (pre-9.8), where the Employee Panel fails to verify that an authenticated employee actually owns the provider account they are updating, letting any low-privileged employee overwrite another employee's cabinet password and hijack that account. Despite the ml_ui classification in this dataset, this is a generic WordPress booking plugin with no AI/ML functionality — it is not part of an LLM pipeline, model serving stack, or agent framework, so it carries no direct AI/ML supply-chain or model-integrity risk. No CVSS score, EPSS data, KEV listing, or public exploit/scanner is currently available, and the vulnerability requires an existing low-privilege authenticated account (Employee Panel access), which limits exploitation to insiders or already-compromised low-priv accounts rather than unauthenticated attackers. If this plugin is deployed anywhere in the organization (including alongside AI tooling on the same WordPress instance), the concrete action is to upgrade to version 9.8 or later immediately and audit provider/employee account activity for unexpected password resets. Security teams should track this as a standard web-application broken access control issue rather than an AI threat intelligence item, and correct the category tag in the source feed if this recurs for other non-AI plugins.
What is the risk?
Low relevance to AI/ML risk posture. The flaw is a classic Insecure Direct Object Reference (IDOR) / broken access control issue in a WordPress booking plugin, not an AI system. Exploitability is moderate-to-easy for an insider (requires only a valid Employee Panel login, no special tooling), but the blast radius is confined to the plugin's own provider accounts and does not touch AI models, training data, inference APIs, or agent tooling. No CVSS/EPSS scoring is published, no CISA KEV listing, and no public exploit or Nuclei template exists at this time, so opportunistic mass exploitation risk is currently low.
How does the attack unfold?
What systems are affected?
| Package | Ecosystem | Vulnerable Range | Patched |
|---|---|---|---|
| Booking for Appointments and Events Calendar | — | — | No patch |
Do you use Booking for Appointments and Events Calendar? You're affected.
How severe is it?
What is the attack surface?
What should I do?
1 stepUpgrade the 'Booking for Appointments and Events Calendar' plugin to version 9.8 or later, which is expected to add proper ownership verification on the provider-update endpoint. Until patched, restrict Employee Panel access to trusted staff only, monitor for unexpected password-reset events on provider/employee accounts, and review recent account activity logs for signs of unauthorized cabinet password changes. Since this is unrelated to AI/ML infrastructure, no AI-specific detection or compensating controls (model monitoring, inference rate limiting, etc.) are applicable.
What does CISA's SSVC say?
Source: CISA Vulnrichment (SSVC v2.0). Decision based on the CISA Coordinator decision tree.
How is it classified?
Which compliance frameworks are affected?
Compliance analysis pending. Sign in for full compliance mapping when available.
Frequently Asked Questions
What is CVE-2026-14212?
This vulnerability affects the 'Booking for Appointments and Events Calendar' WordPress plugin (pre-9.8), where the Employee Panel fails to verify that an authenticated employee actually owns the provider account they are updating, letting any low-privileged employee overwrite another employee's cabinet password and hijack that account. Despite the ml_ui classification in this dataset, this is a generic WordPress booking plugin with no AI/ML functionality — it is not part of an LLM pipeline, model serving stack, or agent framework, so it carries no direct AI/ML supply-chain or model-integrity risk. No CVSS score, EPSS data, KEV listing, or public exploit/scanner is currently available, and the vulnerability requires an existing low-privilege authenticated account (Employee Panel access), which limits exploitation to insiders or already-compromised low-priv accounts rather than unauthenticated attackers. If this plugin is deployed anywhere in the organization (including alongside AI tooling on the same WordPress instance), the concrete action is to upgrade to version 9.8 or later immediately and audit provider/employee account activity for unexpected password resets. Security teams should track this as a standard web-application broken access control issue rather than an AI threat intelligence item, and correct the category tag in the source feed if this recurs for other non-AI plugins.
Is CVE-2026-14212 actively exploited?
Proof-of-concept exploit code is publicly available for CVE-2026-14212, increasing the risk of exploitation.
How to fix CVE-2026-14212?
Upgrade the 'Booking for Appointments and Events Calendar' plugin to version 9.8 or later, which is expected to add proper ownership verification on the provider-update endpoint. Until patched, restrict Employee Panel access to trusted staff only, monitor for unexpected password-reset events on provider/employee accounts, and review recent account activity logs for signs of unauthorized cabinet password changes. Since this is unrelated to AI/ML infrastructure, no AI-specific detection or compensating controls (model monitoring, inference rate limiting, etc.) are applicable.
What is the CVSS score for CVE-2026-14212?
CVE-2026-14212 has a CVSS v3.1 base score of 4.7 (MEDIUM). The EPSS exploitation probability is 0.29%.
What are the technical details?
Original Advisory
The Booking for Appointments and Events Calendar WordPress plugin before 9.8 does not verify that an authenticated employee (provider) owns the provider account being updated, allowing any employee with an Employee Panel login to overwrite another employee's cabinet password and take over their account.
Exploitation Scenario
A disgruntled or compromised low-privilege employee logs into the plugin's Employee Panel with their own valid credentials, then manipulates the provider-update request (e.g., changing a provider/user ID parameter) to target a different employee's account instead of their own. Because the plugin does not verify ownership of the account being modified, the request succeeds and overwrites the target employee's cabinet password, granting the attacker full access to that colleague's provider account and any data or scheduling privileges tied to it.
Weaknesses (CWE)
CWE-639 — Authorization Bypass Through User-Controlled Key: The system's authorization functionality does not prevent one user from gaining access to another user's data or record by modifying the key value identifying the data.
- [Architecture and Design] For each and every data access, ensure that the user has sufficient privilege to access the record that is being requested.
- [Architecture and Design, Implementation] Make sure that the key that is used in the lookup of a specific user's record is not controllable externally by the user or that any tampering can be detected.
Source: MITRE CWE corpus.
CVSS Vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:LReferences
- wpscan.com/vulnerability/5afb51cc-8e1e-4c3c-aba6-6789e89161ae/exploitvdb-entrytechnical-description
Timeline
Related Vulnerabilities
CVE-2026-2185810.0n8n: Input Validation flaw enables exploitation
Same attack type: Auth BypassGHSA-vvpj-8cmc-gx3910.0picklescan: security flaw enables exploitation
Same attack type: Auth BypassCVE-2025-282810.0LangChain RequestsToolkit: SSRF exposes cloud metadata
Same attack type: Auth BypassCVE-2025-5376710.0Azure OpenAI: SSRF EoP, no auth required (CVSS 10)
Same attack type: Auth BypassCVE-2026-2603010.0semantic-kernel: Code Injection enables RCE
Same attack type: Auth Bypass